Ceramic Tile Advice Forums - John Bridge Ceramic Tile

Ceramic Tile Advice Forums - John Bridge Ceramic Tile (https://www.johnbridge.com/vbulletin/index.php)
-   The Mud Box (https://www.johnbridge.com/vbulletin/forumdisplay.php?f=5)
-   -   Server failure thread Sep-2019 (https://www.johnbridge.com/vbulletin/showthread.php?t=128086)

davem 09-27-2019 07:03 PM

Server failure thread Sep-2019
 
Hi folks, as in the announcement:

Quote:

Originally Posted by The Announcement
Hello All,

I'm sure you noticed we've been offline for several days. Our server experience a major hardware failure and our host had quite a battle getting us moved to new hardware.

They got us back online briefly today, 27-Sep-2019, but our backup was from 9/21 and we had some error messages on many pages.

I got rid of the error messages, then restored a newer backup and our image attachments from my latest backup (9/23/19 at about 4:45 a.m)

From what I can tell the server crashed sometime on 9/24 prior to my 4:45 backup so we lost about a day of content. I sincerely apologize for that.

Moving forward, we are going to migrate to a new type of virtual server "on the cloud". The advantage is that if something fails we can instantly come back up on a different server almost instantly. That's the theory anyway. I think it's our best path forward in hopes to avoid this type of catastrophic failure.

If you see any error messages or anything else strange, please post here. Please note the url of the page where you see the problem. For instance, as I type this I am at https://www.johnbridge.com/vbulletin...=newthread&f=5.

Again, I appreciate your help and patience.

Kman 09-27-2019 07:34 PM

You know, every time this happens, I have to do some work around the house.

You'd think the guys that handle our server would keep that in mind.....

:D

Dave Taylor 09-28-2019 09:20 AM

Welcome back!!!
 
Ya'll had me worried for a bit. :)

John Bridge 09-28-2019 02:46 PM

Who me, worry? :)

Worry doesn't quite describe it. The web site is my life. It's been around since the 1990s. We have done everything we knew how to do up to this point to keep things humming, and, as it turns out, it wasn't enough.

In the early years, after outgrowing the usual hosting services, we moved to a virtual dedicated server. After causing it to break down a time or two we moved to a leased dedicated server, and we've had to upgrade to a larger one of those. Now I guess we broke that somehow.

I can't wait to get on that cloud. :)

Gozo 09-28-2019 05:15 PM

Hey Dave,
It seems the apostrophes from the historical backups are getting converted to weird characters. The current post, like John?s above look OK.
Take a look at this for an example:
https://www.johnbridge.com/vbulletin...ostcount=21670

When I looked at this post in preview, it looks OK; but in the thread, the apostrophe shows as a ?. Also, the linked post, is OK in the single post view, but weird in the thread.
Maybe it’s just my browser.

chuck stevenson 09-28-2019 06:37 PM

Glad ya'll and all got this issue sorted out. I tried logging in the other day and got nothing. :scratch:

davem 09-28-2019 06:41 PM

Thank you Jeff, I will look into it.

Edit: I made a change and the historic post you linked looks ok, but I still see a ? in your post above.

Interesting, Chuck's "ya'll" looks ok....

Ah, I think I know what happened. Chuck posted right after I made the change so his is ok. Your's shows a ? When I edit it, and I see you edited it. So I think going forward all posts with apostrophes will be ok. I hope. :D

Tiger Mountain Tile Inc 09-29-2019 11:20 AM

That's a big outage! Glad you guys got things up and running again.:)

Tiger Mountain Tile Inc 09-29-2019 11:28 AM

1 Attachment(s)
I think I just found a bug:

I'm showing that I have 1 notification below my user name in the upper right. A private message.

When I go to click on the message it shows a box about 1 inch lower than the notification. When I move the mouse down to click the box it disappears.

edit: I just uploaded a screen shot. This is on Chrome.

Attachment 210241

Gozo 09-29-2019 11:49 AM

Looks like whatever you’ve done in the restore process has fixed the odd character issue I mentioned in post #5. Looked at a few of the offending examples and they look good now. Thanks for the heroic effort! :clap2:

davem 09-29-2019 05:23 PM

Jeff :D

Jim, I just sent myself a private message. I see the notice and also get the popup when I click it. I click on the popup and it takes me to the message.

Is anyone else seeing what Jim is seeing?

cx 09-29-2019 07:27 PM

PM feature working fine on my end, Dave, when the site is working fine, which is still not always after the big outage.

John Bridge 09-30-2019 02:28 PM

I vote we far DaveM. It's all gotta be his fault. ;)

Dave Taylor 10-04-2019 04:24 AM

DaveM is pretty "far" already. :)

Tiger Mountain Tile Inc 10-05-2019 11:17 AM

1 Attachment(s)
Seems to be working now. The box is now right below the notification box and I can mouse over it.

Good work, Dave! :D

Attachment 210320

ceramictec 10-28-2019 03:47 PM

1 Attachment(s)
Weird I can’t login on my Firefox browser but on my phone Safari browser I can.

Attachment 210536

Tiger Mountain Tile Inc 10-28-2019 04:04 PM

It's been off and on for me that last hour or so.

davem 10-29-2019 08:50 AM

Hmm that's interesting Brian. I saw a bit of that first few days as DNS servers updated but not after that. Could you try typing the whole thing out with the https:// on the front of it? https://www.johnbridge.com/forum

Jim, I wasn't aware of any issues this morning. Please let me know if it continues.

ss3964spd 10-29-2019 09:53 AM

Haven't experienced any issues at all today, using MS Edge.

cx 10-29-2019 10:15 AM

I've not seen any problems today, Dave. Using Firefox browser.

davem 10-29-2019 10:49 AM

Thanks for the feedback :)

ceramictec 10-29-2019 11:59 AM

it was only down for me for a few hours using my desktop browser.
I even went to a web proxy (HMA) and tried to log in and it didnt work.
Like I said it was ok on my safari iphone.

Tiger Mountain Tile Inc 11-01-2019 03:47 PM

For me, it was offline two separate times in about 30 minutes. I tried both firefox and chrome and neither worked.

It's been fine today so far

davem 11-01-2019 07:14 PM

Thanks for the info :)

Tiger Mountain Tile Inc 11-30-2019 05:49 PM

1 Attachment(s)
3:43 pm Pacific time. Chrome browser. Clicked again a second later and it was back to normal.

Attachment 211021

davem 11-30-2019 09:07 PM

Yikes. Now that we are on the Bezos machine I thought we were going to be bigger, stronger, faster...

John Bridge 12-01-2019 07:28 AM

I didn't even know we were on the "Bezos machine." I thought we were off in the clouds somewhere.

Maybe we are. :D

davem 12-01-2019 08:05 AM

Yeah, AWS is Amazon Web Service. Big cloud. :)

cx 12-01-2019 10:08 AM

And the only actually profitable part of Amazon if my reading on the subject is correct. Scary how a retail company can take over the world without being otherwise profitable, eh? :D

davem 12-01-2019 02:07 PM

Makes you wonder what 'not profitable' means. Numbers can be cooked so many ways, it's a bunch of shenanigans if you ask me. :blah:

cx 12-01-2019 03:26 PM

I couldn't argue with that, Dave. It certainly had huge income early on for a company not making any money, but I recall thinking the business plan couldn't possibly work over the long haul. Shows what I know about runnin' a bidness, eh? :D

It's certainly been profitable for young Mr. Bezos, whether the retail end technically shows a profit or no.

Tiger Mountain Tile Inc 12-07-2019 02:26 PM

2 Attachment(s)
This may not be a server issue but I can't figure out what I did wrong.

I was using the Advanced Search to look for the thread on wet saw tents. This is what I used for parameters:

Attachment 211139

Which gave me these two results:

Attachment 211140

Neither of which is this thread that has the term "tent" right in the title, has more than 10 posts, and at least one post by myself.

https://www.johnbridge.com/vbulletin...light=saw+tent

That's the thread that I was looking for all along. Any idears?

cx 12-07-2019 02:55 PM

You did not axe it to search Titles, Jim. So it didn't. :)

Tiger Mountain Tile Inc 12-07-2019 03:53 PM

the word "tent" is in the posts also

edit: I think I figured it out. Apparently, the specified user has to use the word "tent" in a post.

I liked it better when I could blame the server. :D

Tool Guy - Kg 12-07-2019 05:46 PM

If you suspect that the title of the thread contains the word, “tent”, you could have changed the default selection of “Search Entire Posts” over to “Search Titles Only”. The drop down is located under the “Keyword” box in the upper left corner. This will filter away the bazillions of posts that contain the keyword. Your desired thread is the number two result when you make this change to the way you searched.

:)

davem 12-07-2019 07:43 PM

vBulletin search is kind of weak. I can try rebuilding the search index but will do that and let it run overnight. Way back when I added the google custom search near the bottom of the screen, sometimes it works better.


All times are GMT -6. The time now is 03:24 PM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2018 John Bridge & Associates, LLC